Passend zu unserem Buch welches im kommenden Monat erscheinen wird, möchte ich euch heute die Wenn-Funktion in Excel zeigen. Sie kann bei der Erstellung einiger Tabellen sehr sinnvoll sein und die Wenn-Funktion wird vollautomatisch funktionieren wenn diese korrekt erstellt worden ist.

Was ist die Wenn-Funktion?

Mit der Wenn-Funktion in Excel können verschiedene Werte miteinander verglichen werden. Dies ist zum Beispiel sinnvoll wenn wir eine Liste unserer Kunden erstellen möchten und alle unsere Kunden einen Rabatt entsprechend des Jahresumsatzes erhalten. Dies mag sich nun im ersten Moment zwar unsinnig anhören, ist aber sehr hilfreich wenn man einen Kundenstamm >100 Kunden hat. Doch gleich mehr zur Ausführung der Wenn-Funktion.

Wie wird die Wenn-Funktion angewendet?

Im folgenden Beispiel gehen wir davon aus, dass wir ein Großhändler sind. Unsere Kunden erhalten ab einem bestimmten Umsatz aus dem Jahr 2017 einen zusätzlichen Rabatt für das Jahr 2018 eingeräumt. Für dieses Beispiel werden wir allen Kunden deren Umsatz größer als 750€ war, einen Rabatt von 10% einräumen. Alle Kunden die unter den 750€ waren, erhalten keinen Rabatt. So könnte unsere erstelle Tabelle in etwa aussehen:

Excel Wenn-Funktion

Unter dem Punkt „Kunde“ sind all unsere Kunden aufgeführt und unter „Umsatz“ deren jeweilige Jahresumsätze. Nun möchten wir natürlich unter „Rabattsatz“ sehen, welcher Kunde welchen Rabattsatz für das laufende Geschäftsjahr erhalten wird. Die Rabattsätze, wie auch die Voraussetzungen diesen zu bekommen sind rechts der Tabelle zu sehen. Also gehen wir nun wie folgt vor.

Die Formel für die Wenn-Funktion

So sieht die Formel die wir eingeben müssen aus. Keine Angst, ich werde dir diese Formel unten noch einmal Schritt für Schritt erklären!

Wenn-Funktion Formel

Die Formel lautet  –>  =WENN(D4<$H$8;$G$8;WENN(D4>$H$9;$G$9;““))  <–. Doch wie setzt sich diese Formel zusammen? Hierzu fangen wir ganz von vorne an!

Eine einfache Formel der Wenn-Funktion sieht so aus –> =WENN(Wahrheitstest;Wert_wenn_wahr;Wert_wenn_falsch) <–.

Jede Formel die in Excel eingegeben wird, fängt mit einem Gleichheitszeichen an. Nach dem Gleichheitszeichen folgt dann der Startbegriff für die jeweilige Formel (in diesem Fall „Wenn“) und eine offene Klammer  –> =WENN(  <–. Danach erst können wir mit der Eingabe unserer Werte starten.

Der erste Wert ist der Wahrheitswert, in der Tabelle oben habe ich eingegeben –> D4<$H$8 <–. Das bedeutet nichts anderes als: Wenn das Feld in D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt)Die einzelnen Eingaben in der Wenn-Funktion werden durch ein Semikolon getrennt. Das erste Semikolon nach der Eingabe vom Wahrheitswert hat hierbei die Bedeutung „Dann„. Zusammengefasst bis hierhin bedeutet –> =WENN(D4<$H$8; <– also: 

Wenn das Feld D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt) dann …

Nun geht es weiter mit „Wert_wenn_wahr„. Hier habe ich in der o. g. Formel eingegeben -> $G$8 <- und damit gebe ich Excel vor, welchen Wert in dieses Feld eingetragen werden soll, wenn der (Umsatz des Kunden) kleiner ist als der (Mindesumsatz für Rabatt). Auch nach dieser Eingabe folgt wieder ein Semikolon, dies hat jedoch nicht die Bedeutung „Dann„wie nach der ersten Eingabe, sondern „Sonst„. Zusammengefasst bis hierhin bedeutet –> =WENN(D4<$H$8;$G$8; <– also: 

Wenn das Feld D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt) dann trage in dieses Feld den Inhalt aus dem Feld G8 ein, ansonsten …

Im Grunde genommen wäre die Formel nun schon bis auf „Wert_wenn_falsch“ fertig und wir könnten als letzten Wert ganz einfach  –> „“ <– eintragen und die offene Klammer vom Anfang schließen. Dies würde folgendes bezwecken: Wenn das Feld D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt) dann trage in dieses Feld den Inhalt aus dem Feld G8 ein, ansonsten lasse dieses Feld leer. Die beiden Gänsefüßchen bedeuten in Excel nur, dass das Feld dann leer bleiben soll. 

Da wir haben nicht nur prüfen müssen ob der Umsatz kleiner ist, brauchen wir hier noch mehr Text. Die Methode ich angewendet habe nennt sich „verschachtelte Wenn-Funktion„. In dieser öffnen wir an dem Punkt wo eigentlich der „“Sonst„-Wert stehen sollte eine neue Wenn-Funktion. Daher wiederholen wir die Formel, die wir bereits zur Prüfung vom ersten Wert eingegeben haben auch zur Prüfung vom zweiten Wert. Nachdem wir auch den zweiten Wert geprüft haben, beenden wir die Eingabe im Bereich“Wert_wenn_falsch“ mit dem Leerzeichen („“) und schließen die Klammer. Nun ist unsere gesamte Formel fertig, doch fassen wir noch einmal zusammen.

–> =WENN(D4<$H$8;$G$8;WENN(D4>$H$9;$G$9;““)) <–  Diese Formel bedeutet im Endeffekt nichts anderes als: Wenn das Feld D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt) dann trage in dieses Feld den Inhalt aus dem Feld G8 ein, ansonsten prüfe ob das Feld D4 (Umsatz des Kunden) größer ist als H9 (Mindestumsatz für Rabatt) sollte dies der Fall sein füge den Inhalt aus dem Feld G9 in dieses Feld ein. Sollte auch diese Prüfung nicht zutreffen, lasse dieses Feld leer.

Da es nur zwei Möglichkeiten gibt die wir in unserer Formel berücksichtigt haben, ist das eintragen der Gänsefüßchen am Schluss reine Formsache. Ein Fall der eintreten könnte ist der, dass ein Kunde einen Umsatz von genau 750€ erzielt hat. in diesem Fall müssen wir unsere zweite Formel –> =WENN(D4<$H$8;$G$8;WENN(D4>$H$9;$G$9;““)) <– um ein Gleichheitszeichen ergänzen und würde dann so aussehen –> =WENN(D4<$H$8;$G$8;WENN(D4>=$H$9;$G$9;““)) <–.

Und die ergänzte Formel hat dann folgende Bedeutung: Wenn das Feld D4 (Umsatz des Kunden) kleiner ist als H8 (Mindestumsatz für Rabatt) dann trage in dieses Feld den Inhalt aus dem Feld G8 ein, ansonsten prüfe ob das Feld D4 (Umsatz des Kunden) größer oder gleich ist als H9 (Mindestumsatz für Rabatt) sollte dies der Fall sein füge den Inhalt aus dem Feld G9 in dieses Feld ein. Sollte auch diese Prüfung nicht zutreffen, lasse dieses Feld leer.

Wie wird die Wenn-Funktion auf den Rest der Tabelle übertragen?

Bis hierhin haben wir die Formel eingegeben und die Frage geklärt, welcher Kunde einen Rabatt gewährt bekommt. Doch dies haben wir nur für einen Kunden eingegeben, sollen wir die Formel etwa für jeden Kunden wiederholen? Natürlich nicht, denn wir können die einmalig eingegebene Formel für alle anderen Kunden ebenfalls verwenden.

Hierzu klicken wir einmal auf das Feld in welches wir die Formel eingegeben haben und fahren mit dem Mauszeiger unten rechts in das Feld, bis ein schwarzes Kreuz zusehen ist. Wenn das Kreuz zu sehen ist, klicken wir und halten die Maustaste gedrückt. Während wir die Maustaste gedrückt haben, kann das Feld heruntergezogen werden, sodass die Formel auf alle leeren Felder übertragen wird.

Doch Achtung! Bitte setze vorher die $-Zeichen wie ich es oben gemacht habe, da die Formel sonst nicht funktionieren wird. Warum dies notwendig ist, wirst du in einem anderen Beitrag von mir erfahren.

Wenn-Funktion Formel für alle

 

Ich hoffe dass ich dir mit diesem Artikel weiterhelfen konnte und freue mich über eine 5-Sterne Bewertung. Sollte in diesem Beitrag etwas unklar sein, oder du über weitere Excel-Themen lesen möchtest, dann schreibe es in die Kommentare.